summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-09 21:01:20 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-13 00:38:10 -0400
commitdc24ee62eec9406e32e5c2fa88b9a5762ae096fc (patch)
treedb1cc068062ab363c9c12f45d32dcbd32a8832ad
parenta2bf7bda4cade6e6b035ab7ad06acdfbf377c7a2 (diff)
gnu: libextractor: Modernize.
* gnu/packages/gnunet.scm (libextractor): Move inputs, native-inputs after arguments. [arguments]: Use gexps. Remove trailing #t. [inputs]: Remove labels and sort. Change-Id: Ia3950630bd0985e106fb92cce3f92732e93970df
-rw-r--r--gnu/packages/gnunet.scm132
1 files changed, 65 insertions, 67 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index a28419213b..59b41edf6f 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>
-;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,76 +83,74 @@
(define-public libextractor
(package
- (name "libextractor")
- (version "1.13")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/libextractor/libextractor-"
- version ".tar.gz"))
- (sha256
- (base32
- "0mgprmwdhdwq9xhfxfhcncd304425nvcc4zi8ci5f0nja4n333xv"))))
- (build-system gnu-build-system)
- ;; WARNING: Checks require /dev/shm to be in the build chroot, especially
- ;; not to be a symbolic link to /run/shm.
- ;; FIXME:
- ;; The following dependencies are all optional, but should be
- ;; available for maximum coverage:
- ;; * librpm (rpm) ; investigate failure
- ;; * libtidy-html (tidy-html) ; investigate failure
- (inputs
- `(("exiv2" ,exiv2)
- ("bzip2" ,bzip2)
- ("flac" ,flac)
- ("file" ,file) ;libmagic, for the MIME plug-in
- ("glib" ,glib)
- ("giflib" ,giflib)
- ("gstreamer" ,gstreamer)
- ("gst-plugins-base" ,gst-plugins-base)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("libarchive" ,libarchive)
- ("libgsf" ,libgsf)
- ("libjpeg" ,libjpeg-turbo)
- ("libltdl" ,libltdl)
- ("libmpeg2" ,libmpeg2)
- ("libmp4v2" ,libmp4v2)
- ("libsmf" ,libsmf)
- ("libogg" ,libogg)
- ("libtiff" ,libtiff)
- ("libvorbis" ,libvorbis)
- ("zlib" ,zlib)))
- (native-inputs
- (list pkg-config))
- (outputs '("out"
- "static")) ; 420 KiB .a files
- (arguments
- `(#:configure-flags
- (list (string-append "--with-ltdl="
- (assoc-ref %build-inputs "libltdl")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'move-static-libraries
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Move static libraries to the "static" output.
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib"))
- (static (assoc-ref outputs "static"))
- (slib (string-append static "/lib")))
- (mkdir-p slib)
- (for-each (lambda (file)
- (install-file file slib)
- (delete-file file))
- (find-files lib "\\.a$"))
- #t))))))
- (synopsis "Library to extract meta-data from media files")
- (description
- "GNU libextractor is a library for extracting metadata from files. It
+ (name "libextractor")
+ (version "1.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libextractor/libextractor-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0mgprmwdhdwq9xhfxfhcncd304425nvcc4zi8ci5f0nja4n333xv"))))
+ (build-system gnu-build-system)
+ (outputs '("out"
+ "static")) ; 420 KiB .a files
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-ltdl="
+ #$(this-package-input "libltdl")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'move-static-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Move static libraries to the "static" output.
+ (let* ((out #$output)
+ (lib (string-append out "/lib"))
+ (slib (string-append #$output:static "/lib")))
+ (mkdir-p slib)
+ (for-each (lambda (file)
+ (install-file file slib)
+ (delete-file file))
+ (find-files lib "\\.a$"))))))))
+ ;; WARNING: Checks require /dev/shm to be in the build chroot, especially
+ ;; not to be a symbolic link to /run/shm.
+ ;; FIXME:
+ ;; The following dependencies are all optional, but should be
+ ;; available for maximum coverage:
+ ;; * librpm (rpm) ; investigate failure
+ ;; * libtidy-html (tidy-html) ; investigate failure
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list bzip2
+ exiv2
+ file ;libmagic, for the MIME plug-in
+ flac
+ gdk-pixbuf
+ giflib
+ glib
+ gst-plugins-base
+ gstreamer
+ libarchive
+ libgsf
+ libjpeg-turbo
+ libltdl
+ libmp4v2
+ libmpeg2
+ libogg
+ libsmf
+ libtiff
+ libvorbis
+ zlib))
+ (synopsis "Library to extract meta-data from media files")
+ (description
+ "GNU libextractor is a library for extracting metadata from files. It
supports a very large number of file formats, including audio files, document
files, and archive files. Each file format is implemented as a plugin, so
new formats can be added easily. The package also contains a command-line
tool to extract metadata from a file and print the results.")
- (license license:gpl3+)
- (home-page "https://www.gnu.org/software/libextractor/")))
+ (license license:gpl3+)
+ (home-page "https://www.gnu.org/software/libextractor/")))
(define-public libmicrohttpd
(package