summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2022-12-01 21:11:50 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-08 13:07:46 +0100
commitdc2fa2ed0b49025dd25b11522ae4ed33774f7b69 (patch)
treece4199151d0f518da11b54fb49bd7b6b35f67836
parent9336baf258d6fc19e5dfa5bcfc7892d239f24837 (diff)
gnu: minetest: Add minetest-oneblock.
* gnu/packages/minetest.scm (minetest-oneblock): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/minetest.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index f5671241a7..0f017217de 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -746,3 +746,26 @@ stopping before signals.
advtrains up to version 2.2.1.")
(license (list license:cc-by-sa3.0 license:agpl3+))
(properties `((upstream-name . "orwell/basic_trains")))))
+
+(define-public minetest-oneblock
+ (package
+ (name "minetest-oneblock")
+ (version "2022-09-01")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NO411/oneblock")
+ (commit "3582c825137e61b3d2ae3d60b8b9746acd6dfe3d")))
+ (sha256
+ (base32
+ "1pkdrj99qqwmz7c86w2mh081ynyxhiwv2rl01xjm1wfpazx5zhdg"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (home-page "https://github.com/NO411/oneblock")
+ (synopsis "Build your island in the sky with random items!")
+ (description
+ "This package provides an extension of the Minetest game that lets you
+build your island in the sky. Every 30 seconds you will receive a random
+block or item from the oneblock to expand the island!")
+ (license license:gpl3+)
+ (properties `((upstream-name . "NO11/oneblock")))))