summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:18:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:40 +0200
commitdc887a8c1f7702c73c43a0c851a560207e692006 (patch)
tree6153f2712d463e9761537a6bab07c3d6f32b4885
parentabc76749d335a0726a89febfc4ff1898b1737957 (diff)
gnu: Add texlive-optexcount.
* gnu/packages/tex.scm (texlive-optexcount): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2a7cbb7acf..82085c496c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2920,6 +2920,32 @@ in this texmf tree. The script may be used for archiving purposes or to speed
up later TeX runs.")
(license license:artistic2.0)))
+(define-public texlive-optexcount
+ (package
+ (name "texlive-optexcount")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/optexcount/"
+ "scripts/optexcount/"
+ "source/support/optexcount/")
+ (base32
+ "0rjyhyirkx11v04c8b0kjjz8745kdnj190vzkyyzafwnzfcbd754")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "optexcount")))
+ (inputs (list python))
+ (home-page "https://ctan.org/pkg/optexcount")
+ (synopsis "Python script for counting words in OpTeX documents")
+ (description
+ "OpTeXcount is a basic Python utility that analyzes OpTeX source code.
+It is inspired by already existing TeXcount for LaTeX. The functionality is
+really lightweight and basic. It counts words and other elements of OpTeX
+document and sorts them out into individual categories. Users can print the
+source code with highlighted words using several colors, so they see what is
+considered as word, header etc.")
+ (license license:expat)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")