summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:23:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:09 +0200
commitdcff8457b1244610ef7773cdf8672d41cf2d73ce (patch)
tree5fab0f5cfe8247527a2474ae25a7ffc8295c3f47
parent7977913c25205d3efa1fde1f14263cdd0ee3f13f (diff)
gnu: Add texlive-auto-pst-pdf-lua.
* gnu/packages/tex.scm (texlive-auto-pst-pdf-lua): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5b6ee015cc..b44bcc91f6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14868,6 +14868,28 @@ provided box macros are @code{\\lapbox}, @code{\\marginbox},
@code{\\minsizebox}, @code{\\maxsizebox} and @code{\\phantombox}.")
(license license:lppl1.3+)))
+(define-public texlive-auto-pst-pdf-lua
+ (package
+ (name "texlive-auto-pst-pdf-lua")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/auto-pst-pdf-lua/"
+ "tex/latex/auto-pst-pdf-lua/")
+ (base32
+ "1wkhdg47qjpc0yv47z1jmrmpnq8zic6bqfmay3ry6lvv47f775z1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-iftex))
+ (home-page "https://ctan.org/pkg/auto-pst-pdf-lua")
+ (synopsis "Using LuaLaTeX together with PostScript code")
+ (description
+ "This package is a slightly modified version of @code{auto-pst-pdf} by
+Will Robertson, which itself is a wrapper for @code{pst-pdf} by Rolf
+Niepraschk. The package allows the use of LuaLaTeX together with PostScript
+related code, e.g., PSTricks.")
+ (license license:lppl1.3c)))
+
(define-public texlive-qrcode
(package
(name "texlive-qrcode")