summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2021-04-14 05:20:06 -0500
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:20:59 +0000
commitdde7bb4f74d13ab9412514bb936189c2176d8438 (patch)
treedef634526f8ef18a55c446e435007b45a460ecb3
parent610f66cb4523622b745682c2b51e163220043192 (diff)
gnu: Add go-github-com-logrusorgru-aurora.
* gnu/packages/golang-xyz.scm (go-github-com-logrusorgru-aurora): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I14ac154d222a444ad83022e72d79a7937462c7a5
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c495d1faca..7852c6b8ed 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1362,6 +1362,30 @@ customized globally.")
database/sql package.")
(license license:expat)))
+(define-public go-github-com-logrusorgru-aurora
+ (package
+ (name "go-github-com-logrusorgru-aurora")
+ (version "2.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/logrusorgru/aurora")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1ck2j2ff2avph07vgq0r1y7hmbqgvk339rvph45dcwgci23lb3pf"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/logrusorgru/aurora"))
+ (home-page "https://github.com/logrusorgru/aurora")
+ (synopsis "Ultimate ANSI colors for Golang")
+ (description
+ "This package provides ANSI colors for Golang. The package supports
+Printf/Sprintf etc.")
+ (license license:unlicense)))
+
(define-public go-github-com-kballard-go-shellquote
;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
(let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")