summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2019-09-26 23:44:30 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-28 22:56:40 +0200
commitde3896fb79984d545e7fec0b5e4f1ba37983fbce (patch)
tree73431cf56c8f9bbcb6667a8add7a95eb46bb6513
parent569832dfafbf3f31bcc2ed4545d88a0634205df1 (diff)
gnu: Add ell.
* gnu/packages/linux.scm (ell): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 027c920357..876eb005af 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanović <stefanx2ovic@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5969,3 +5970,43 @@ have to construct the archives directly, without using the archiver.")
(description "inputattach dispatches input events from several device
types and interfaces and translates so that the X server can use them.")
(license license:gpl2+)))
+
+(define-public ell
+ (package
+ (name "ell")
+ (version "0.23")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/libs/ell/ell.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qhlcwhn0gj877yss2ymx1aczghlddzb5v9mm1dgp2zliii3jy10"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dbus-tests
+ (lambda _
+ (substitute* '("unit/test-dbus-message-fds.c"
+ "unit/test-dbus-properties.c"
+ "unit/test-dbus.c")
+ (("/usr/bin/dbus-daemon") (which "dbus-daemon")))
+ #t)))))
+ (inputs
+ `(("dbus" ,dbus)
+ ("libtool" ,libtool)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("pkgconfig" ,pkg-config)
+ ("automake" ,automake)))
+ (home-page "https://01.org/ell")
+ (synopsis "Embedded Linux Library")
+ (description "The Embedded Linux* Library (ELL) provides core, low-level
+functionality for system daemons. It typically has no dependencies other than
+the Linux kernel, C standard library, and libdl (for dynamic linking). While
+ELL is designed to be efficient and compact enough for use on embedded Linux
+platforms, it is not limited to resource-constrained systems.")
+ (license license:lgpl2.1+)))