summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-01-22 17:58:11 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-22 18:12:09 +0100
commite1dbac04c3b89670ef726a0dafd390e87c6c754f (patch)
treee850374941555c0399f4c241b76008d2a76eb757
parent15eda456a72dc8a8c7a9ea4444475592dcaf1dc9 (diff)
gnu: hpcguix-web: Update to 0.3.0.
* gnu/packages/web.scm (hpcguix-web): Update to 0.3.0. [inputs]: Add GUILE-SYNTAX-HIGHLIGHT. [arguments]: In 'wrap-program' phase, take guile-syntax-highlight into account. * gnu/tests/web.scm (%hpcguix-web-specs): Remove 'define'. * doc/guix.texi (Web Services): Adjust accordingly.
-rw-r--r--doc/guix.texi12
-rw-r--r--gnu/packages/web.scm11
-rw-r--r--gnu/tests/web.scm7
3 files changed, 16 insertions, 14 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index d7e2311a65..507a0d3ee4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -30322,14 +30322,15 @@ Data type for the hpcguix-web service configuration.
@table @asis
@item @code{specs}
A gexp (@pxref{G-Expressions}) specifying the hpcguix-web service
-configuration. The main items available in this spec are:
+configuration as an @code{hpcguix-web-configuration} record. The main
+fields of that record type are:
@table @asis
@item @code{title-prefix} (default: @code{"hpcguix | "})
The page title prefix.
@item @code{guix-command} (default: @code{"guix"})
-The @command{guix} command.
+The @command{guix} command to use in examples that appear on HTML pages.
@item @code{package-filter-proc} (default: @code{(const #t)})
A procedure specifying how to filter packages that are displayed.
@@ -30369,10 +30370,9 @@ A typical hpcguix-web service declaration looks like this:
(service hpcguix-web-service-type
(hpcguix-web-configuration
(specs
- #~(define site-config
- (hpcweb-configuration
- (title-prefix "Guix-HPC - ")
- (menu '(("/about" "ABOUT"))))))))
+ #~(hpcweb-configuration
+ (title-prefix "Guix-HPC - ")
+ (menu '(("/about" "ABOUT")))))))
@end lisp
@quotation Note
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 32bda0b5be..6de462e921 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
-;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
@@ -7710,7 +7710,7 @@ compressed JSON header blocks.
(define-public hpcguix-web
(package
(name "hpcguix-web")
- (version "0.2.0")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7719,7 +7719,7 @@ compressed JSON header blocks.
(file-name (git-file-name name version))
(sha256
(base32
- "1l856d1vr63ns1sp9fm6v97p71mx00769k6lwzqzppsb9clksnwp"))))
+ "1g1sd5d6fhrblqk3rc8hzkk1sxyiilbb45kdgbrfg7ccd1sbic30"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -7744,9 +7744,11 @@ compressed JSON header blocks.
(bs (assoc-ref inputs "guile-bytestructures"))
(json (assoc-ref inputs "guile-json"))
(zlib (assoc-ref inputs "guile-zlib"))
+ (syntax (assoc-ref inputs "guile-syntax-highlight"))
(guile-cm (assoc-ref inputs
"guile-commonmark"))
- (deps (list guile gcrypt git bs zlib guile-cm guix json))
+ (deps (list guile gcrypt git bs zlib guile-cm
+ syntax guix json))
(effective
(read-line
(open-pipe* OPEN_READ
@@ -7776,6 +7778,7 @@ compressed JSON header blocks.
guile-zlib
guile-commonmark
guile-json-4
+ guile-syntax-highlight
bash-minimal))
(home-page "https://github.com/UMCUGenetics/hpcguix-web")
(synopsis "Web interface for cluster deployments of Guix")
diff --git a/gnu/tests/web.scm b/gnu/tests/web.scm
index 7a585e618d..16dc6bea49 100644
--- a/gnu/tests/web.scm
+++ b/gnu/tests/web.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2020-2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2017, 2020-2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
@@ -419,9 +419,8 @@ HTTP-PORT, along with php-fpm."
(define %hpcguix-web-specs
;; Server config gexp.
- #~(define site-config
- (hpcweb-configuration
- (title-prefix "[TEST] HPCGUIX-WEB"))))
+ #~(hpcweb-configuration
+ (title-prefix "[TEST] HPCGUIX-WEB")))
(define %hpcguix-web-os
(simple-operating-system