summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-05 16:35:21 -0400
committerDavid Thompson <davet@gnu.org>2015-06-15 20:27:38 -0400
commite259bdf008f28924cc97edaede3b4a7caf4502ad (patch)
tree354972fb7aba4ee37fea1aa3cc49e24bf0c3b12c
parentde59d31607c2c6a2e630fca056f7785b5104242b (diff)
gnu: Add ruby-connection-pool.
* gnu/packages/ruby.scm (ruby-connection-pool): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 073dc4b8d0..e7b3c5d247 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -416,3 +416,25 @@ generation of complex SQL queries and adapts to various relational database
implementations.")
(home-page "https://github.com/rails/arel")
(license license:expat)))
+
+(define-public ruby-connection-pool
+ (package
+ (name "ruby-connection-pool")
+ (version "2.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mperham/connection_pool/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02s5rwhmgy8qqns7a5y1daa0yaw38x6lzpwyvmy46h1yrj9mc6zf"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Generic connection pool for Ruby")
+ (description "Connection_pool provides a generic connection pooling
+interface for Ruby programs.")
+ (home-page "https://github.com/mperham/connection_pool")
+ (license license:expat)))