summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Alesius <paul@unnservice.com>2023-02-08 14:27:48 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-08 15:04:55 -0500
commite266a8deced88c234fec4949b68c38cb38f9f6fb (patch)
treef94f7585d9abd04fe733e3565fb95612ff4520a7
parent71db3fbf712be2e95213d5fab55eca9782818133 (diff)
gnu: Add rust-rustfix-0.6.
* gnu/packages/crates-io.scm (rust-rustfix-0.6): New variable. (rust-rustfix-0.5): Inherit from rust-rustfix-0.6. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 21 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3837ed779a..1cabe8da00 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -48948,8 +48948,28 @@ rustc compiler.")
"This package provides a tool to manipulate rustdoc comments.")
(license license:asl2.0)))
+(define-public rust-rustfix-0.6
+ (package
+ (name "rust-rustfix")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustfix" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0apkjxv3z70vhnyz2kpwsivvndk6qk7kkp0rf7sg8pk7q1gy02vg"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/rust-lang/rustfix")
+ (synopsis "Automatically apply the suggestions made by rustc")
+ (description "Automatically apply the suggestions made by rustc.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustfix-0.5
(package
+ (inherit rust-rustfix-0.6)
(name "rust-rustfix")
(version "0.5.1")
(source
@@ -48975,12 +48995,7 @@ rustc compiler.")
("rust-env-logger" ,rust-env-logger-0.6)
("rust-log" ,rust-log-0.4)
("rust-proptest" ,rust-proptest-0.9)
- ("rust-tempdir" ,rust-tempdir-0.3))))
- (home-page "https://github.com/rust-lang/rustfix")
- (synopsis "Automatically apply the suggestions made by rustc")
- (description
- "Automatically apply the suggestions made by rustc.")
- (license (list license:expat license:asl2.0))))
+ ("rust-tempdir" ,rust-tempdir-0.3))))))
(define-public rust-rustfix-0.4
(package/inherit rust-rustfix-0.5