summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-13 16:58:13 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:09 -0400
commite2d1eaef29076e3559861212b5bc865dbaf02698 (patch)
tree174fd936291588f072c3b60ee0052d9a3420410e
parent8dad48c8041f4f6f6fbf6be16850baaa77540d84 (diff)
gnu: python-shiboken-6: Update to 6.6.2.
* gnu/packages/qt.scm (python-shiboken-6, python-pyside-6): Update to 6.6.2. (python-shiboken-6)[properties]: Set upstream-name. (python-pyside-6)[arguments]<#:configure-flags>: Set CMAKE_INSTALL_RPATH. Change-Id: I098481f860c3bc97a629cca719305b2d00c3eace Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/qt.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ef19384b92..74dadf5c64 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4603,7 +4603,7 @@ color-related widgets.")
(package
(inherit python-shiboken-2)
(name "python-shiboken-6")
- (version "6.5.2")
+ (version "6.6.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://qt/QtForPython/pyside6/PySide6-"
@@ -4611,7 +4611,7 @@ color-related widgets.")
version ".tar.xz"))
(sha256
(base32
- "1a0v9mjlcjbffm4lf5cfg45hvqai9654p95ygj5cjhfd9z8z3nwh"))))
+ "1w690jpxrski7c71gx05q5fvl2117lnjj5ih8iwckx3s9mlhnqhl"))))
(build-system cmake-build-system)
(inputs
(modify-inputs (package-inputs python-shiboken-2)
@@ -4631,7 +4631,8 @@ color-related widgets.")
"-DCMAKE_SKIP_RPATH=TRUE"
(string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath="
#$output "/lib")
- #$flags))))))
+ #$flags))))
+ (properties `((upstream-name . "pyside-setup")))))
(define-public python-pyside-2
(package
@@ -4767,12 +4768,16 @@ generate Python bindings for your C or C++ code.")
#:configure-flags
#~(list "-DBUILD_TESTS=FALSE"
(string-append "-DPYTHON_EXECUTABLE="
- (search-input-file %build-inputs
- "/bin/python")))
+ (search-input-file %build-inputs "/bin/python")))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'go-to-source-dir
(lambda _ (chdir "sources/pyside6")))
+ (add-after 'go-to-source-dir 'set-rpath
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("CMAKE_INSTALL_RPATH")
+ (string-append "CMAKE_INSTALL_RPATH " #$output "/lib")))))
(add-after 'go-to-source-dir 'fix-qt-module-detection
(lambda _
(substitute* "cmake/PySideHelpers.cmake"