summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 15:05:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 15:29:14 +0200
commite74e9f62405e6ff20f2a23c2c6c64c7007c52b9e (patch)
tree1aecddaeb3cb5909a82dd682fe5564ec77db78fb
parentefec1a8453380c61bf87e978a91989267b91ac4c (diff)
gnu: r-cellid: Move out of experiments section.
* gnu/packages/bioconductor.scm (r-cellid): Move from experiments section to packages section.
-rw-r--r--gnu/packages/bioconductor.scm90
1 files changed, 45 insertions, 45 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b60b98d7bb..b19daa2e3f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1436,51 +1436,6 @@ curated cell type labels, for use in procedures like automated annotation of
single-cell data or deconvolution of bulk RNA-seq.")
(license license:gpl3)))
-(define-public r-cellid
- (package
- (name "r-cellid")
- (version "1.8.1")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "CelliD" version))
- (sha256
- (base32
- "0vigvqjrlqbi5kviaj8qvyq3v8afgbc5pjrz7zmx2ckf4hdp0g03"))))
- (properties `((upstream-name . "CelliD")))
- (build-system r-build-system)
- (propagated-inputs
- (list r-data-table
- r-biocparallel
- r-fastmatch
- r-fgsea
- r-ggplot2
- r-glue
- r-irlba
- r-matrix
- r-matrixstats
- r-pbapply
- r-rcpp
- r-rcpparmadillo
- r-reticulate
- r-rtsne
- r-seurat
- r-stringr
- r-tictoc
- r-singlecellexperiment
- r-summarizedexperiment
- r-umap))
- (native-inputs (list r-knitr r-scater))
- (home-page "https://bioconductor.org/packages/CelliD")
- (synopsis
- "Single cell gene signature extraction using multiple correspondence analysis")
- (description
- "CelliD is a clustering-free method for extracting per-cell gene
-signatures from scRNA-seq. CelliD allows unbiased cell identity recognition
-across different donors, tissues-of-origin, model organisms and single-cell
-omics protocols. The package can also be used to explore functional pathways
-enrichment in single cell data.")
- (license license:gpl3)))
-
(define-public r-champdata
(package
(name "r-champdata")
@@ -4220,6 +4175,51 @@ scRNA-seq data. A flexible beta-binomial error model that accounts for
stochastic dropout events as well as systematic allelic imbalance is used.")
(license license:gpl3)))
+(define-public r-cellid
+ (package
+ (name "r-cellid")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CelliD" version))
+ (sha256
+ (base32
+ "0vigvqjrlqbi5kviaj8qvyq3v8afgbc5pjrz7zmx2ckf4hdp0g03"))))
+ (properties `((upstream-name . "CelliD")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-data-table
+ r-biocparallel
+ r-fastmatch
+ r-fgsea
+ r-ggplot2
+ r-glue
+ r-irlba
+ r-matrix
+ r-matrixstats
+ r-pbapply
+ r-rcpp
+ r-rcpparmadillo
+ r-reticulate
+ r-rtsne
+ r-seurat
+ r-stringr
+ r-tictoc
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-umap))
+ (native-inputs (list r-knitr r-scater))
+ (home-page "https://bioconductor.org/packages/CelliD")
+ (synopsis
+ "Single cell gene signature extraction using multiple correspondence analysis")
+ (description
+ "CelliD is a clustering-free method for extracting per-cell gene
+signatures from scRNA-seq. CelliD allows unbiased cell identity recognition
+across different donors, tissues-of-origin, model organisms and single-cell
+omics protocols. The package can also be used to explore functional pathways
+enrichment in single cell data.")
+ (license license:gpl3)))
+
(define-public r-coverageview
(package
(name "r-coverageview")