summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 08:28:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 08:29:00 -0400
commite784cba4235c64d9a409e5368ad7d23bcb5d4a16 (patch)
treeaaec1def32b7bb48fdb38eef5bbd98e8b8233f0f
parent555e3a951f787ba22795c3c84186df13430eab0d (diff)
gnu: libxml++: Remove fix-documentation phase.
* gnu/packages/gnome.scm (libxml++) [arguments]: Delete field.
-rw-r--r--gnu/packages/gnome.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9266c354cb..a30bf4051b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8674,30 +8674,6 @@ the available networks and allows users to easily switch between them.")
(sha256
(base32 "13jlhz57yjxapplflm8aarczxv6ll3d336y1446mr5n4ylkcc1xz"))))
(build-system gnu-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-documentation
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (let* ((xsl-version #$(package-version docbook-xsl))
- (xsldoc (string-append "xml/xsl/docbook-xsl-"
- xsl-version)))
- (substitute* '("examples/dom_xpath/example.xml"
- "docs/manual/libxml++_without_code.xml")
- (("http://.*/docbookx\\.dtd")
- (search-input-file (or native-inputs inputs)
- "xml/dtd/docbook/docbookx.dtd")))
- (setenv "SGML_CATALOG_FILES"
- (search-input-file (or native-inputs inputs)
- (string-append
- xsldoc "/catalog.xml")))
- (substitute* "docs/manual/docbook-customisation.xsl"
- (("http://docbook.sourceforge.net/release/xsl\
-/current/html/chunk.xsl")
- (search-input-file (or native-inputs inputs)
- (string-append xsldoc
- "/html/chunk.xsl"))))))))))
(propagated-inputs
(list libxml2)) ;required by .pc file
(native-inputs