summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-21 01:12:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-21 01:12:21 +0100
commite8e9a7898e9d8eb85ad54afaec6a1e619bf8b74f (patch)
treedf931b7cd9fcc86237451ac380266ffecc13213a
parent0cbebc6521aaaddd903a44a543aec3c6eaf6c8eb (diff)
gnu: emacs-js2-mode: Update to 20201220.
* gnu/packages/emacs-xyz.scm (emacs-js2-mode): Update to 20201220.
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bdf094fb44..aa17c7b751 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8171,33 +8171,31 @@ to all the other commands, too.")
(license license:gpl3+)))
(define-public emacs-js2-mode
- (let ((commit "40aab27581279d0fdbfeb9afeb85f39d401a927f")
- (revision "1"))
- (package
- (name "emacs-js2-mode")
- (version (git-version "20190219" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mooz/js2-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ysd0ji3vvk2zpjcg1wl7b2hva8471vq0ypib4h6spnpjdr43vzk"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("make" "test")))
- (home-page "https://github.com/mooz/js2-mode/")
- (synopsis "Improved JavaScript editing mode for Emacs")
- (description
- "Js2-mode provides a JavaScript major mode for Emacs that is more
+ (package
+ (name "emacs-js2-mode")
+ (version "20201220")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mooz/js2-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00jy917cgp5xzfgs4m0spzlbqk8mg63layin8nxmn2647rfjnik4"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("make" "test")))
+ (home-page "https://github.com/mooz/js2-mode/")
+ (synopsis "Improved JavaScript editing mode for Emacs")
+ (description
+ "Js2-mode provides a JavaScript major mode for Emacs that is more
advanced than the built-in javascript-mode. Features include accurate syntax
highlighting using a recursive-descent parser, on-the-fly reporting of syntax
errors and strict-mode warnings, smart line-wrapping within comments and
strings, and code folding.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-nodejs-repl
(package