summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 13:44:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:34 -0400
commite91180f450a3ce0c99b778da0d43d11729adfa6f (patch)
tree65c029cdab3482def7e9b161920e1b6be179cdee
parenteba493b369e3353d757a82e116682fdd5ea90b47 (diff)
gnu: Add python-ordered-set.
* gnu/packages/python-xyz.scm (python-ordered-set): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 43009da908..9591ced6da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29425,6 +29425,32 @@ simple mock/record and a complete capture/replay framework.")
interfaces.")
(license license:bsd-3)))
+(define-public python-ordered-set
+ (package
+ (name "python-ordered-set")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ordered-set" version))
+ (sha256
+ (base32 "1a34fg3r3480nfm6652kyqql3lwixf8jirzdja9camvnr128wjk9"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-cython python-pytest))
+ (home-page "https://github.com/simonpercivall/orderedset")
+ (synopsis "Ordered Set implementation in Cython")
+ (description "This library provides an @code{OrderedSet} data type that
+works like a regular set, but remembers insertion order. It supports the full
+Python @code{set} interface.")
+ (license license:asl2.0)))
+
(define-public python-orgparse
(package
(name "python-orgparse")