summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-30 14:29:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-03-30 14:31:02 +0200
commite93a570fd6f2c81cca0dbbbe3faf36e8f5afffe2 (patch)
tree8efa4587b5c4b72d9609a49d5fb8845320a0293a
parent96e81b18b9dd6a7fdc2d178ee8d1542f8d55826f (diff)
gnu: Add r-enmix.
* gnu/packages/bioconductor.scm (r-enmix): New variable.
-rw-r--r--gnu/packages/bioconductor.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 5a59ab86eb..a224eecd70 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6454,6 +6454,48 @@ other types of genomic data that produce counts, including ChIP-seq, SAGE and
CAGE.")
(license license:gpl2+)))
+(define-public r-enmix
+ (package
+ (name "r-enmix")
+ (version "1.34.02")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ENmix" version))
+ (sha256
+ (base32
+ "0rn541xfsxfdyzy3dn727bwrfpkgp12282lax7xg1j8584mk4pcf"))))
+ (properties `((upstream-name . "ENmix")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotationhub
+ r-biobase
+ r-doparallel
+ r-dynamictreecut
+ r-experimenthub
+ r-foreach
+ r-genefilter
+ r-geneplotter
+ r-gplots
+ r-gtools
+ r-illuminaio
+ r-impute
+ r-iranges
+ r-matrixstats
+ r-minfi
+ r-preprocesscore
+ r-quadprog
+ r-rpmm
+ r-s4vectors
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/release/bioc/html/ENmix.html")
+ (synopsis
+ "Quality control and analysis tools for Illumina DNA methylation BeadChip")
+ (description
+ "This package provides tools for quality control, analysis and
+visualization of Illumina DNA methylation array data.")
+ (license license:artistic2.0)))
+
(define-public r-ensembldb
(package
(name "r-ensembldb")