summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-21 09:55:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 13:10:33 +0200
commite9f01bfc976707af45dde0ab022318f74246e164 (patch)
tree7aca838f9512a30e57d62f776ca92a3dc2f3d791
parent0ea5ef000d51bf53d7eb9dd0768c3d22f65c422f (diff)
gnu: python-setuptools-for-tensorflow: Patch for Python 3.10 compatibility.
* gnu/packages/python-xyz.scm (python-setuptools-for-tensorflow)[arguments]: Patch collections imports; remove wininst support.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d6dba68404..10b28f0888 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2311,8 +2311,20 @@ other machines, such as over the network.")
(substitute* "setuptools/py33compat.py"
(("html_parser.HTMLParser\\(\\).unescape")
"html.unescape"))
+ ;; collections classes have moved in Python 3.10
+ (substitute* "pkg_resources/_vendor/pyparsing.py"
+ (("collections.MutableMapping")
+ "collections.abc.MutableMapping")
+ (("collections.Iterable")
+ "collections.abc.Iterable"))
;; This needs distutils.msvc9compiler
- (delete-file "setuptools/tests/test_msvc.py"))))))
+ (delete-file "setuptools/tests/test_msvc.py")
+ ;; See https://github.com/pypa/setuptools/issues/2558
+ (delete-file "setuptools/command/bdist_wininst.py")
+ (substitute* "setuptools/command/install_scripts.py"
+ (("bw_cmd =.*") "\n")
+ (("is_wininst =.*")
+ "is_wininst = False\n")))))))
(native-inputs
(list python-pytest python-mock python-six)))))