summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-09-25 03:49:05 -0400
committerArun Isaac <arunisaac@systemreboot.net>2021-09-29 00:06:14 +0530
commitea75da9ec9b423b37a0f02691b3d5da8798be834 (patch)
treeab53af142615f0e017622f88dc3c78984691c223
parent5edfa6d15e5bb92609ecff7e37e3985eced1dd4d (diff)
gnu: Add python-face.
* gnu/packages/python-xyz.scm (python-face): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 16f778dd76..29feffae74 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27182,6 +27182,45 @@ location. This small Python module determines the appropriate
platform-specific directories, e.g. the ``user data dir''.")
(license license:expat)))
+(define-public python-face
+ (package
+ (name "python-face")
+ (version "20.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "face" version))
+ (sha256
+ (base32 "0gpd9f0rmbv3rd2szi2na37l29fabkwazikjrxc6wca1lddwlnbx"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-boltons" ,python-boltons)))
+ (home-page "https://github.com/mahmoud/face")
+ (synopsis "CLI parsing and dispatching microframework")
+ (description "@code{python-face} is a Pythonic microframework for building
+command-line applications.
+
+@itemize
+@item First-class subcommand support
+@item Powerful middleware architecture
+@item Separate parser layer
+@item Built-in flagfile support
+@item Handy testing utilities
+@item Themeable help display
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-box
(package
(name "python-box")