summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-01-27 19:21:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-31 21:02:33 +0000
commiteab88f2e458035560310f5dd2be92ee47183f8b9 (patch)
treea8f8305a332c66df8871c9037bff2515b0fc89e2
parentb41bcc04340d5fcd2e5f80222d1446b6f5cc974c (diff)
gnu: Remove go-github-com-kisielk-gotool.
* gnu/packages/golang-check.scm (go-github-com-kisielk-gotool): Delete variable. Change-Id: Ic99bba40f4cd66335656f27bf7dd97d1b90bb8f1 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-check.scm1
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index c7b6e94791..b9dd235cc2 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -73,7 +73,6 @@
(delete 'build))))
(propagated-inputs
(list go-github-com-burntsushi-toml
- go-github-com-kisielk-gotool
go-golang-org-x-exp
go-golang-org-x-mod
go-golang-org-x-tools))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7851d17d52..20fb76b1c8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10091,30 +10091,6 @@ be used as both a binary and a library.")
(native-inputs '())
(inputs '())))
-(define-public go-github-com-kisielk-gotool
- (package
- (name "go-github-com-kisielk-gotool")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kisielk/gotool")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "14af2pa0ssyp8bp2mvdw184s5wcysk6akil3wzxmr05wwy951iwn"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/kisielk/gotool"))
- (home-page "https://github.com/kisielk/gotool")
- (synopsis "Go library of utility functions")
- (description
- "This package contains utility functions used to implement the standard
-@code{cmd/go} tool, provided as a convenience to developers who want to write
-tools with similar semantics.")
- (license license:expat)))
-
(define-public go-go-uber-org-zap
(package
(name "go-go-uber-org-zap")