summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Becze <mjbecze@riseup.net>2021-04-14 05:20:10 -0500
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:21:00 +0000
commitf0a3c722019f408a1dd14c5bf3e4d0bd9d6374ce (patch)
tree7295cf5d2c551c5f77d47b9b4a546173989fc954
parent558a41968aae022b2aa7f4b2182ad60a515cab3e (diff)
gnu: Add wally-cli.
* gnu/packages/flashing-tools.scm (wally-cli): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I43f495c2251acf38db72d59c449700899a252671
-rw-r--r--gnu/packages/flashing-tools.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 6165845261..9c1bdd02bd 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2023 B. Wilson <x@wilsonb.com>
@@ -40,6 +41,7 @@
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages admin)
@@ -57,6 +59,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -626,6 +629,42 @@ formats, and can perform many different manipulations.")
It can be used to upload images to I.MX SoC's using at least their boot ROM.")
(license license:bsd-3)))
+(define-public wally-cli
+ ;; Version with updated dependencies is not released yet, see
+ ;; <https://github.com/zsa/wally-cli/pull/7>.
+ (let ((commit "b0fafe52cc7fb9d55f2b968d4548c99917c7325c")
+ (revision "0"))
+ (package
+ (name "wally-cli")
+ (version (git-version "2.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zsa/wally-cli")
+ (commit commit)))
+ (sha256
+ (base32 "09phq2g51x7rlalzb87aqf48p3j4s7s5jdf5vdf48l9805hi2yha"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:install-source? #f
+ #:import-path "github.com/zsa/wally-cli"))
+ (native-inputs
+ (list go-github-com-briandowns-spinner
+ go-github-com-google-gousb
+ go-github-com-logrusorgru-aurora
+ go-github-com-marcinbor85-gohex
+ go-gopkg-in-cheggaaa-pb-v1
+ pkg-config))
+ (home-page "https://ergodox-ez.com/pages/wally")
+ (synopsis "Flashing tool for ZSA keyboards")
+ (description
+ "This tool is for flashing custom layouts to
+@url{https://ergodox-ez.com/,ZSA keyboards}.")
+ (license license:expat))))
+
(define-public qdl
(let ((commit "13681fcb359c9f9c32a17a91d3dd20df2e413b6d")
(revision "1"))