summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-07 22:03:56 -0400
committerLeo Famulari <leo@famulari.name>2017-04-08 13:24:31 -0400
commitf0e9fda6beaf3c44993b2cc7264fa05ad887b0a8 (patch)
treeda29a33adb9ed413cd12d2a6b64c02b8e0b61fea
parent99a8c8bd7ddd2806db7c6402ec1307adada717d5 (diff)
gnu: certbot, python-acme: Update to 0.13.0.
* gnu/packages/tls.scm (certbot, python-acme, python2-acme): Update to 0.13.0. [arguments]: Add 'patch-dependency' phase.
-rw-r--r--gnu/packages/tls.scm27
1 files changed, 23 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 5f06140e72..ac5e406c7f 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -469,18 +469,29 @@ security, and applying best practice development processes.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "0.12.0")
+ (version "0.13.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1pzv8fcfwdqzvvpyhgjz412is0b98yj9495k8sidzzqgbdmvlp50"))))
+ "05cqadwzgfcianw3v0qxwja65dxnzw429f7dk8w0mnh21pib72bl"))))
(build-system python-build-system)
+
+ ;; TODO factorize the 'docs' phase and share arguments between python-acme
+ ;; and certbot.
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'install 'docs
+ (add-after 'unpack 'patch-dependency
+ ;; This module is part of the Python standard library, so we don't
+ ;; need to use an external package.
+ ;; https://github.com/certbot/certbot/pull/2249
+ (lambda _
+ (substitute* "setup.py"
+ (("'argparse',") ""))
+ #t))
+ (add-after 'build 'docs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(man (string-append out "/share/man/man1"))
@@ -526,12 +537,20 @@ security, and applying best practice development processes.")
(uri (pypi-uri name version))
(sha256
(base32
- "1dw86gb8lyap5ckjawmli1hxgbchw2g62g1lqfvxyqjv0df94waa"))))
+ "1wq0khcf4ixda71cgfd9rkqqzx6j8hp8ha0cssvjzjnsgrsdffpn"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-dependency
+ ;; This module is part of the Python standard library, so we don't
+ ;; need to use an external package.
+ ;; https://github.com/certbot/certbot/pull/2249
+ (lambda _
+ (substitute* "setup.py"
+ (("'argparse',") ""))
+ #t))
(add-after 'build 'docs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))