summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-23 12:02:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 16:40:18 +0200
commitf1750236c139a5015631db0f4b70a4d8b7d76b5b (patch)
tree844ad260d9437c1bcbb54199ca0b4de9c7e7e5f8
parentc0278aa51e08bc5c9916f2b58b7b45676863844f (diff)
gnu: Add r-asset.
* gnu/packages/bioconductor.scm (r-asset): New variable.
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 038532c915..a0ecec8498 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2317,6 +2317,33 @@ reproducible gene expression signatures capable of accurately distinguishing
tumor samples from healthy controls.")
(license license:artistic2.0)))
+(define-public r-asset
+ (package
+ (name "r-asset")
+ (version "2.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ASSET" version))
+ (sha256
+ (base32
+ "029acl5k9d4hnvy3jia9cr4rk6w31zn8b5s79i6lazq1cp236hbg"))))
+ (properties `((upstream-name . "ASSET")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mass r-msm r-rmeta))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/ASSET")
+ (synopsis
+ "Subset-based association analysis of heterogeneous traits and subtypes")
+ (description
+ "This package is an R program for the subset-based analysis of
+heterogeneous traits and disease subtypes. ASSET allows the user to search
+through all possible subsets of z-scores to identify the subset of traits
+giving the best meta-analyzed z-score. Further, it returns a p-value
+adjusting for the multiple-testing involved in the search. It also allows for
+searching for the best combination of disease subtypes associated with each
+variant.")
+ (license license:gpl2)))
+
(define-public r-atena
(package
(name "r-atena")