summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-07-09 18:34:37 +0000
committerLudovic Courtès <ludo@gnu.org>2022-07-19 21:39:53 +0200
commitf2e6891f7de2ade67e0e03ca2c80f6c50c0a7b1f (patch)
tree267df17f30a1f31bb2b400aaadda0124724d71f2
parentfce8de7800cb260df358b4715ff52b51d12ebf70 (diff)
gnu: Add python-bsdiff4.
* gnu/packages/python-xyz.scm (python-bsdiff4): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ab4755fcc..11f709f7b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30182,3 +30182,24 @@ GeoPackage Binary")
GeoJSON to WKT/WKB (Well-Known Text/Binary) or GeoPackage Binary, and vice
versa. Extended WKB/WKT are also supported.")
(license license:asl2.0)))
+
+(define-public python-bsdiff4
+ (package
+ (name "python-bsdiff4")
+ (version "1.2.2")
+ (home-page "https://github.com/ilanschnell/bsdiff4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fa0vkmbr0a9xifq7i5gfcf7ifn739i1fdij8awynm299fsqvvhx"))))
+ (build-system python-build-system)
+ (synopsis "Binary diff and patch using the BSDIFF4 format")
+ (description "This package provides a Python library for the @code{bsdiff}
+binary diff utility. It also provides two command-line tools, @code{bsdiff4}
+and @code{bspatch4}.")
+ (license license:bsd-2)))