summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-03-19 14:39:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-03-19 14:39:21 +0100
commitf3958db4ad24bb35213d1022de582c4f51720602 (patch)
treeb75b130a44515b916bdb710c0f95fc06d53c3445
parent8b8e7971ba14b8bb8249ac4e133670bc87e3adb0 (diff)
gnu: snakemake-5: Use G-expression.
* gnu/packages/python-xyz.scm (snakemake-5)[arguments]: Use #$output instead of referencing "out" in outputs. Change-Id: Ie3d6d5788c4db4060e26079cb81441f5bc6f08e8
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4a5375839..dc211ff782 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12821,19 +12821,18 @@ approach.")
(build-system python-build-system)
(arguments
;; TODO: Package missing test dependencies.
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; For cluster execution Snakemake will call Python. Since there is
- ;; no suitable PYTHONPATH set, cluster execution will fail. We fix
- ;; this by calling the snakemake wrapper instead.
- (add-after 'unpack 'call-wrapper-not-wrapped-snakemake
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "snakemake/executors/__init__.py"
- (("\\{sys.executable\\} -m snakemake")
- (string-append (assoc-ref outputs "out")
- "/bin/snakemake")))
- #t)))))
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; For cluster execution Snakemake will call Python. Since there is
+ ;; no suitable PYTHONPATH set, cluster execution will fail. We fix
+ ;; this by calling the snakemake wrapper instead.
+ (add-after 'unpack 'call-wrapper-not-wrapped-snakemake
+ (lambda _
+ (substitute* "snakemake/executors/__init__.py"
+ (("\\{sys.executable\\} -m snakemake")
+ (string-append #$output "/bin/snakemake"))))))))
(propagated-inputs
(list python-appdirs
python-configargparse