summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-10-02 20:31:21 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-04 16:36:58 +0200
commitf666b9b478a306314f426c0ee93a7ebb91f6f60f (patch)
treed02ed6add0a7436c958f152c710881c4a0a94d21
parente0e65ed69d62a759c1b88f035f246baef47bd551 (diff)
gnu: Add mjpg-streamer.
* gnu/packages/video.scm: (mjpg-streamer): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/video.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b6acebcecc..3733b93415 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -446,6 +447,51 @@ library.")
(home-page "http://libquicktime.sourceforge.net/")
(license license:lgpl2.1+)))
+(define-public mjpg-streamer
+ (package
+ (name "mjpg-streamer")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jacksonliam/mjpg-streamer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0w81pg228154blzbzr590xwhcll9baxyqxl6wxrgqsi9cd7pzq23"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (with-directory-excursion "mjpg-streamer-experimental/www"
+ (for-each delete-file-recursively
+ '("cambozola.jar"
+ "JQuerySpinBtn.css"
+ "JQuerySpinBtn.js"
+ "jquery.js"
+ "jquery.rotate.js"
+ "jquery.ui.core.min.js"
+ "jquery.ui.custom.css"
+ "jquery.ui.tabs.min.js"
+ "jquery.ui.widget.min.js")))))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda* _
+ (chdir "mjpg-streamer-experimental"))))))
+ (inputs `(("libjpeg-turbo" ,libjpeg-turbo)))
+ (synopsis "Stream JPEG over IP network")
+ (description "Command line application that copies JPEG frames from one or
+more input plugins to multiple output plugins. It can be used to stream JPEG
+files over an IP-based network from a webcam to various types of viewers such
+as Chrome, Firefox, Cambozola, VLC, mplayer, and other software capable of
+receiving MJPG streams.")
+ (home-page "https://github.com/jacksonliam/mjpg-streamer")
+ (license license:gpl2+)))
+
(define-public mjpegtools
(package
(name "mjpegtools")