summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-27 06:35:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-27 06:35:38 +0200
commitf95498c92e48dc731be538dda67ff112dcfce98e (patch)
tree87c1c70c6c24e40e0ba6abcae4b16d9f87ec9cfd
parente1ca41185242abacba48e78945361592096ca125 (diff)
gnu: python-h11: Update to 0.14.0.
* gnu/packages/python-web.scm (python-h11): Update to 0.14.0. [build-system]: Use pyproject-build-system. [arguments]: Remove.
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4de6dee44c..d6dd1032aa 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1384,21 +1384,14 @@ for use in Python programs that implement HTTP/2.")
(define-public python-h11
(package
(name "python-h11")
- (version "0.12.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h11" version))
(sha256
- (base32 "0hk0nll6qazsambp3kl8cxxsbl4gv5y9252qadyk0jky0sv2q8j7"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ (base32 "17b97c56y31hi0n0x0cb5a87x4xr9jijf2y06pzj0977k6zgn6cg"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-pytest))
(home-page "https://github.com/python-hyper/h11")