summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-09 18:16:33 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 23:00:21 +0200
commitf9551e9df3b7422b49ede93c3701255733064869 (patch)
treecc0a1f4bbd1d548336cd2a71cfd97b9a0ecf26e6
parente1c0f26ec58556e0ad55277276e17af02c3e6822 (diff)
gnu: meson: Introduce versioned 'meson-0.60' variable.
While at it, change inheritance such that newest comes first. * gnu/packages/build-tools.scm (meson-0.63): Move to the top. (meson-0.60): Inherit from MESON-0.63. (meson-0.59): Inherit from MESON-0.60. Don't use PACKAGE/INHERIT. (meson): Turn into alias for MESON-0.60.
-rw-r--r--gnu/packages/build-tools.scm34
1 files changed, 19 insertions, 15 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 8923d179db..b5b9d501f9 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -263,10 +263,10 @@ files and generates build instructions for the Ninja build system.")
;; X11 license.
(license (list license:bsd-3 license:x11)))))
-(define-public meson
+(define-public meson-0.63
(package
(name "meson")
- (version "0.60.3")
+ (version "0.63.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -274,9 +274,7 @@ files and generates build instructions for the Ninja build system.")
version ".tar.gz"))
(sha256
(base32
- "13mrrizg4vl6n5k7fz6amyafnn3i097dcarr552qc0ca6nlmzjl7"))
- (patches (search-patches
- "meson-allow-dirs-outside-of-prefix.patch"))))
+ "1gwba75z47m2hv3w08gw8sgqgbknjr7rj1qwr510bgknxwbjy8hn"))))
(build-system python-build-system)
(arguments
`(;; FIXME: Tests require many additional inputs and patching many
@@ -309,11 +307,10 @@ files}, are written in a custom domain-specific language (@dfn{DSL}) that
resembles Python.")
(license license:asl2.0)))
-;;; This older Meson variant is kept for now for gtkmm and others that may
-;;; have problems with 0.60.
-(define-public meson-0.59
- (package/inherit meson
- (version "0.59.4")
+(define-public meson-0.60
+ (package
+ (inherit meson-0.63)
+ (version "0.60.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -321,14 +318,16 @@ resembles Python.")
version ".tar.gz"))
(sha256
(base32
- "117cm8794h291lca1wljz1pwnzidgbvrpg3mw3np6ksma368hyd7"))
+ "13mrrizg4vl6n5k7fz6amyafnn3i097dcarr552qc0ca6nlmzjl7"))
(patches (search-patches
"meson-allow-dirs-outside-of-prefix.patch"))))))
-(define-public meson-0.63
+;;; This older Meson variant is kept for now for gtkmm and others that may
+;;; have problems with 0.60.
+(define-public meson-0.59
(package
- (inherit meson)
- (version "0.63.2")
+ (inherit meson-0.60)
+ (version "0.59.4")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mesonbuild/meson/"
@@ -336,7 +335,12 @@ resembles Python.")
version ".tar.gz"))
(sha256
(base32
- "1gwba75z47m2hv3w08gw8sgqgbknjr7rj1qwr510bgknxwbjy8hn"))))))
+ "117cm8794h291lca1wljz1pwnzidgbvrpg3mw3np6ksma368hyd7"))
+ (patches (search-patches
+ "meson-allow-dirs-outside-of-prefix.patch"))))))
+
+;; TODO: Bump this in the next rebuild cycle.
+(define-public meson meson-0.60)
(define-public premake4
(package