summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 16:32:35 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:43 +0100
commitf9913977bf7933e88811019687388ca2900c2345 (patch)
tree48ca5b4f8194ee998e43ae28cb0f1e3c068bc5c5
parent3c1c562288c490ff64ca114e96f69d33cf81e2d6 (diff)
gnu: Add picmi.
* gnu/packages/games.scm (picmi): New variable.
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b3d0900217..96ceafff8f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7963,3 +7963,41 @@ to assist in learning basic vocabulary.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public picmi
+ (package
+ (name "picmi")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/picmi-" version ".tar.xz"))
+ (sha256
+ (base32 "0z9mpmv49w914gqdx274brdzl6d1bz9j9nkvbwgmr3iq1ba49m3f"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdeclarative" ,kdeclarative)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knewstuff" ,knewstuff)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Number logic game")
+ (description "Picmi is a number logic game in which cells in a grid have
+to be colored or left blank according to numbers given at the side of the
+grid. The aim is to reveal a hidden picture.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))