summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:56:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:06 +0200
commitf9aeaee2dbb6380021b63a5db446ce48fe76a8c1 (patch)
treed903bedca05b502480a600f41a92a002cf8519b9
parent749e4be61ad567a8179a68ce8c80984415b15cb3 (diff)
gnu: Add texlive-xetex-pstricks.
* gnu/packages/tex.scm (texlive-xetex-pstricks): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bdc7d5c896..4e4eba1219 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7419,6 +7419,29 @@ XeLaTeX. As such, it has the same user interface and the same capabilities.")
Sanskrit in Kannada and for Kannada itself.")
(license license:lppl1.3+)))
+(define-public texlive-xetex-pstricks
+ (package
+ (name "texlive-xetex-pstricks")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xetex/xetex-pstricks/"
+ "tex/xelatex/xetex-pstricks/"
+ "tex/xetex/xetex-pstricks/")
+ (base32
+ "195zjdxddlwl69gnp2x3jg3l8gn36mxsdbz03qs0r940frx533ls")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xetex-pstricks")
+ (synopsis "Running PSTricks under XeTeX")
+ (description
+ "The package provides an indirection scheme for XeTeX to use the PSTricks
+@file{xdvipdfmx.cfg} configuration file, so that XeTeX documents will load it
+in preference to the standard pstricks.con configuration file. With this
+configuration, many PSTricks features can be used in XeLaTeX or plain XeTeX
+documents.")
+ (license license:public-domain)))
+
(define-public texlive-currfile
(package
(name "texlive-currfile")