summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-10 20:23:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-10 20:23:46 +0200
commitfa0d5854ef9105b7585b9c7f9d8dcc2966e254e0 (patch)
treed68b1a6d024d92f23877d327f0138cf9baf06a95
parentc1f4073ff53aa6b958441b7457692a1e146ab565 (diff)
gnu: ToME4: Fix FTBFS with GCC 7.
* gnu/packages/games.scm (tome4)[arguments]: Preserve CPATH in 'set-sdl-paths' phase..
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a102dc962f..b6a63aba02 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4981,7 +4981,8 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append (assoc-ref inputs "sdl-union")
- "/include/SDL2"))
+ "/include/SDL2:"
+ (getenv "CPATH")))
#t))
(delete 'check)
;; premake doesn't provide install target