summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 11:15:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:02 +0100
commitfc204d24be83a9b822145f3a232491f52304a5b5 (patch)
treed19b1a24b2bc2ae2f6fec5a7661d6cac190bab8c
parent43eb601f76b167f487a819c2ad4b01b0f9c29dab (diff)
gnu: dstat: Don't use unstable tarball.
* gnu/packages/admin.scm (dstat)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f6b70ca6db..ebc893608a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1979,22 +1979,22 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
(package
(name "dstat")
(version "0.7.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dagwieers/dstat/archive/"
- version ".tar.gz"))
- (file-name (string-append "dstat-" version ".tar.gz"))
- (sha256
- (base32
- "16286z3y2lc9nsq8njzjkv6k2vyxrj9xiixj1k3gnsbvhlhkirj6"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dagwieers/dstat.git")
+ (commit version)))
+ (file-name (git-file-name "dstat" version))
+ (sha256
+ (base32 "0sbpna531034gr40w4g9cwz35s2fpf9h654paznsxw9fih91rfa5"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;; no make check
+ `(#:tests? #f ; no make check
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list (string-append "DESTDIR=" out)
"prefix=/"))
- ;; no configure script
+ ;; No configure script.
#:phases (modify-phases %standard-phases (delete 'configure))))
(inputs `(("python-2" ,python-2)))
(synopsis "Versatile resource statistics tool")