summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:13 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:20:35 -0500
commitfd52a5986f2b1a56bb11facde8e280a074937b6f (patch)
tree19ceeedf2dca184f9014aa24579b2c773dc28615
parent683c8c9db442c77f4636528b6bf421ae98b4251e (diff)
gnu: Add go-github-com-emersion-go-textwrapper.
* gnu/packages/golang.scm (go-github-com-emersion-go-textwrapper): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 52197ee31b..1b24216669 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2107,6 +2107,29 @@ writers can be supplied for alternate environments.")
"The datacounter package provides counters for Go readers and writers.")
(license license:expat)))
+(define-public go-github-com-emersion-go-textwrapper
+ (package
+ (name "go-github-com-emersion-go-textwrapper")
+ (version "0.0.0-20200911093747-65d896831594")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-textwrapper")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lh9d7zvj6gm1rr6sv5xlagklgx9d666hq5srd37a4sdcjkbiqmq"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/emersion/go-textwrapper"))
+ (home-page "https://github.com/emersion/go-textwrapper")
+ (synopsis "Text-wrapping writer for Go")
+ (description
+ "The textwrapper package provides a writer that wraps long text lines to
+a specified length.")
+ (license license:expat)))
+
(define-public go-github-com-aki237-nscjar
(let ((commit "e2df936ddd6050d30dd90c7214c02b5019c42f06")
(revision "0"))