summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-14 15:42:42 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-14 15:42:42 +0200
commitfd67cdb7e3a617bfc7ab5091a6b3bf894cf4c28c (patch)
treed772f947601841c1f7780f94145ad38ab5455a8c
parent62548232711b2f34fa6a03caee2b3cf082c99ada (diff)
gnu: commencement: Clean up 'gnu-make-final' dependencies.
* gnu/packages/commencement.scm (gnu-make-final): Remove GUILE-FINAL from the inputs of 'pkg-config'.
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 26b0a94c74..58ee3ba5d9 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2375,13 +2375,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(define gnu-make-final
;; The final GNU Make, which uses the final Guile.
- ;; FIXME: This is a mistake: we shouldn't be propagating GUILE-FINAL to
- ;; PKG-CONFIG.
- ;; TODO: Fix that on the next rebuild cycle.
(let ((pkg-config (package
(inherit pkg-config)
- (inputs `(("guile" ,guile-final)
- ,@(%boot5-inputs)))
+ (inputs (%boot5-inputs))
(arguments
`(#:implicit-inputs? #f
,@(package-arguments pkg-config))))))