summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-07 22:39:55 +0200
committerMarius Bakke <marius@gnu.org>2020-06-07 22:39:55 +0200
commitfd702f8e95c6e77c8658cf657002d2eb3dad29f9 (patch)
tree5079a06b73cc0a7aa56df7b76e49914596896bae
parent8cbb32da7dfa53b15f2ecec7361e24961bb93bbc (diff)
gnu: python-pyqt: Update to 5.14.2.
* gnu/packages/qt.scm (python-pyqt): Update to 5.14.2. [source](uri): Add PyPI mirror. [source](patches): Remove obsolete. * gnu/packages/patches/pyqt-unbundled-qt.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/pyqt-unbundled-qt.patch19
-rw-r--r--gnu/packages/qt.scm15
3 files changed, 9 insertions, 26 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9bf7e78492..ac095dd77c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1395,7 +1395,6 @@ dist_patch_DATA = \
%D%/packages/patches/pygpgme-disable-problematic-tests.patch \
%D%/packages/patches/pyqt-configure.patch \
%D%/packages/patches/pyqt-public-sip.patch \
- %D%/packages/patches/pyqt-unbundled-qt.patch \
%D%/packages/patches/python-2-deterministic-build-info.patch \
%D%/packages/patches/python-2.7-adjust-tests.patch \
%D%/packages/patches/python-2.7-search-paths.patch \
diff --git a/gnu/packages/patches/pyqt-unbundled-qt.patch b/gnu/packages/patches/pyqt-unbundled-qt.patch
deleted file mode 100644
index 5c91ed031c..0000000000
--- a/gnu/packages/patches/pyqt-unbundled-qt.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Remove test for bundled Qt which breaks dependent applications. This has
-been fixed in 5.13.
-
-Taken from Arch Linux:
-https://git.archlinux.org/svntogit/packages.git/tree/trunk/python2-pyqt5-crash-fix.patch?h=packages/pyqt5&id=3e56e11d1fd7b1eac8242ce64c58db2bd9acba20
-
-diff -ur PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in
---- PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in 2019-06-25 14:41:02.000000000 +0200
-+++ PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in 2019-07-01 17:06:34.882644535 +0200
-@@ -151,8 +151,4 @@
- // initialised first (at least for Windows) and this is the only way to
- // guarantee things are done in the right order.
- PyQtSlotProxy::mutex = new QMutex(QMutex::Recursive);
--
-- // Load the embedded qt.conf file if there is a bundled copy of Qt.
-- if (!qpycore_qt_conf())
-- Py_FatalError("PyQt5.QtCore: Unable to embed qt.conf");
- }
-
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b3096a04e..17f7c8e8d0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1945,18 +1945,21 @@ module provides support functions to the automatically generated code.")
(define-public python-pyqt
(package
(name "python-pyqt")
- (version "5.12.3")
+ (version "5.14.2")
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.riverbankcomputing.com/static/"
- "Downloads/PyQt5/" version "/PyQt5_gpl-"
- version ".tar.gz"))
+ ;; PyPI is the canonical distribution point of PyQt. Older
+ ;; releases are available from the web site.
+ (uri (list (pypi-uri "PyQt5" version)
+ (string-append "https://www.riverbankcomputing.com/static/"
+ "Downloads/PyQt5/" version "/PyQt5-"
+ version ".tar.gz")))
+ (file-name (string-append "PyQt5-"version ".tar.gz"))
(sha256
(base32
- "041155bdzp57jy747p5d59740c55yy3241cy1x2lgcdsvqvzmc0d"))
+ "1c4y4qi1l540gd125ikj0al00k5pg65kmqaixcfbzslrsrphq8xx"))
(patches (search-patches "pyqt-configure.patch"
- "pyqt-unbundled-qt.patch"
"pyqt-public-sip.patch"))))
(build-system gnu-build-system)
(native-inputs