summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 01:30:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 01:36:24 +0200
commitfec3fffcd201e9d4e772a39f5373220bbd3b29ac (patch)
treef47ae2c6774cc198c1017df0c1235c6435bd88c8
parentac760f0a62e035a54cb5e0470dfa86d5f5668139 (diff)
gnu: libseccomp: Update to 2.5.2.
* gnu/packages/linux.scm (libseccomp): Update to 2.5.2. [arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0be9834446..b2048f2845 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6426,7 +6426,7 @@ of flash storage.")
(define-public libseccomp
(package
(name "libseccomp")
- (version "2.5.1")
+ (version "2.5.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/seccomp/libseccomp/"
@@ -6434,7 +6434,7 @@ of flash storage.")
"/libseccomp-" version ".tar.gz"))
(sha256
(base32
- "0m8dlg1v7kflcxvajs4p76p275qwsm2abbf5mfapkakp7hw7wc7f"))))
+ "1pw7rd4gwqpmraipgdqkdkhnx4ql35wrn3lnjgl6pncinkgm59hp"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")
@@ -6443,8 +6443,7 @@ of flash storage.")
(lambda _
;; This test does a native system call and fails when
;; run under QEMU user-mode emulation. Just skip it.
- (delete-file "tests/52-basic-load.tests")
- #t)))))
+ (delete-file "tests/52-basic-load.tests"))))))
(native-inputs
`(("gperf" ,gperf)
("which" ,which)))