summaryrefslogtreecommitdiff
path: root/distro
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-11-25 04:04:13 +0000
committerLudovic Courtès <ludo@gnu.org>2012-11-25 16:08:10 +0100
commitfe7777c14b7d5779287acca452dc70e50b026f0c (patch)
treedc011314a840fb314bb62f77b83fb8876dc02d41 /distro
parent7f40d97d88271e8a66eeb7d4739e09937353e8db (diff)
distro: Add GNU Less.
* distro/packages/less.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/less.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/distro/packages/less.scm b/distro/packages/less.scm
new file mode 100644
index 0000000000..fe69164b7f
--- /dev/null
+++ b/distro/packages/less.scm
@@ -0,0 +1,50 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages less)
+ #:use-module (distro packages ncurses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public less
+ (package
+ (name "less")
+ (version "451")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/less/less-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0mszdd9m1dsbg59pav62swg9f87xmjpfspcw2jsazzksciy2is4z"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)))
+ (home-page "https://www.gnu.org/software/less/")
+ (synopsis
+ "GNU less is a program similar to more, but which allows backward
+movement in the file as well as forward movement")
+ (description
+ "GNU less is a program similar to more, but which allows backward
+movement in the file as well as forward movement. Also, less does not
+have to read the entire input file before starting, so with large input
+files it starts up faster than text editors like vi. Less uses
+termcap (or terminfo on some systems), so it can run on a variety of
+terminals. There is even limited support for hardcopy terminals.")
+ (license "GPLv3+"))) ; some files are under GPLv2+ \ No newline at end of file