summaryrefslogtreecommitdiff
path: root/doc/guix.texi
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-01-02 18:44:51 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-31 23:08:38 +0100
commitf85865a05aa3914a478a46e6f10a5ac442d793a2 (patch)
treed370ed6a2e32d796d78bfb30c4de3e0ffb5f26f2 /doc/guix.texi
parentaed385e18ec7b68a0bc1bb4b173aeadc9cd97245 (diff)
home: services: fontutils: Add service value.
* gnu/home/services/fontutils.scm (add-fontconfig-config-file): Add support for multiple paths; (home-fontconfig-service-type): Honor it; * doc/guix.texi (Fonts Services): Document it. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'doc/guix.texi')
-rw-r--r--doc/guix.texi30
1 files changed, 30 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 2b1ad77ba5..64873db00b 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -41130,6 +41130,7 @@ services)}.
* SSH: Secure Shell. Setting up the secure shell client.
* Desktop: Desktop Home Services. Services for graphical environments.
* Guix: Guix Home Services. Services for Guix.
+* Fonts: Fonts Home Services. Services for managing User's fonts.
@end menu
@c In addition to that Home Services can provide
@@ -42014,6 +42015,35 @@ A typical extension for adding a channel might look like this:
@end lisp
@end defvar
+@node Fonts Home Services
+@subsection Fonts Home Services
+
+The @code{(gnu home services fontutils)} module provides services for
+user-specific Fontconfig setup. The
+@uref{https://www.freedesktop.org/wiki/Software/fontconfig,Fontconfig}
+library is used by many applications to access fonts on the system.
+
+@defvar home-fontconfig-service-type
+This is the service type for generating configurations for Fontconfig.
+Its associated value is a list of strings (or gexps) pointing to fonts
+locations.
+
+Generally, it is better to extend this service than to directly
+configure it, as its default value is the default Guix Home's profile
+font installation path (@file{~/.guix-home/profile/share/fonts}). If
+you configure this service directly, be sure to include the above
+directory.
+
+A typical extension for adding an additional font directory might look
+like this:
+
+@lisp
+(simple-service 'additional-fonts-service
+ home-fontconfig-service-type
+ (list "~/.nix-profile/share/fonts"))
+@end lisp
+@end defvar
+
@node Invoking guix home
@section Invoking @command{guix home}