summaryrefslogtreecommitdiff
path: root/emacs/guix-init.el
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-08-06 11:36:53 +0200
committerMathieu Lirzin <mthl@openmailbox.org>2015-08-30 19:20:12 +0200
commitbd6163d13f6445b9a1ec0f85e4a19b9f73ab74ea (patch)
tree99396ace587f2c69c05882e88910fba37fb605fa /emacs/guix-init.el
parenteb097f36b1c3e7a25f1ce212670e8a19788fd195 (diff)
build: Produce 'guix-config' instead of using compile-time tricks.
* emacs/guix-{init,profiles}.el.in: Rename to ... * emacs/guix-{init,profiles}.el: ... these. New files. Use 'guix-config'. * emacs/guix-config.el.in: New file. * emacs.am (nodist_lisp_DATA): Add it. Move them to ... (ELFILES): ... here. * .gitignore, configure.ac: Adjust accordingly.
Diffstat (limited to 'emacs/guix-init.el')
-rw-r--r--emacs/guix-init.el19
1 files changed, 19 insertions, 0 deletions
diff --git a/emacs/guix-init.el b/emacs/guix-init.el
new file mode 100644
index 0000000000..6ea6fcd0b0
--- /dev/null
+++ b/emacs/guix-init.el
@@ -0,0 +1,19 @@
+(require 'guix-config)
+(require 'guix-autoloads)
+
+(defvar guix-load-path guix-emacs-interface-directory
+ "Directory with scheme files for \"guix.el\" package.")
+
+(defcustom guix-package-enable-at-startup t
+ "If non-nil, activate Emacs packages installed in a user profile.
+Set this variable to nil before requiring `guix-init' file to
+avoid loading autoloads of Emacs packages installed in
+`guix-user-profile'."
+ :type 'boolean
+ :group 'guix)
+
+(when guix-package-enable-at-startup
+ (require 'guix-emacs)
+ (guix-emacs-load-autoloads 'all))
+
+(provide 'guix-init)