summaryrefslogtreecommitdiff
path: root/gnu/home
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2023-03-05 17:38:50 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-03-16 14:32:50 +0100
commit193f547ca35eb49ef57bd9a25b67cb3965f10b03 (patch)
tree6bf8fa7915d2b148f50c756627d467afce547b99 /gnu/home
parent2c2f382e757d5eef39e8460a20ac75a1b1f8b22e (diff)
gnu: home: services: Add home-znc-service-type.
* gnu/home/services/messaging.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/guix/POTFILES.in: Likewise. * doc/guix.texi (Messaging Home Services): Document it in new subsection.
Diffstat (limited to 'gnu/home')
-rw-r--r--gnu/home/services/messaging.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnu/home/services/messaging.scm b/gnu/home/services/messaging.scm
new file mode 100644
index 0000000000..d403b84ac9
--- /dev/null
+++ b/gnu/home/services/messaging.scm
@@ -0,0 +1,73 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home services messaging)
+ #:use-module (srfi srfi-26)
+
+ #:use-module (ice-9 match)
+
+ #:use-module (shepherd support)
+
+ #:use-module (gnu home services)
+ #:use-module (gnu home services shepherd)
+ #:use-module (gnu packages messaging)
+ #:use-module (gnu services configuration)
+ #:use-module (gnu services shepherd)
+ #:use-module (guix records)
+ #:use-module (guix gexp)
+
+ #:export (home-znc-configuration
+ home-znc-service-type))
+
+;;;
+;;; Znc.
+;;;
+(define-record-type* <home-znc-configuration>
+ home-znc-configuration make-home-znc-configuration
+ home-znc-configuration?
+ (znc home-znc-znc ;string
+ (default znc))
+ (extra-options home-znc-extra-options ;list of string
+ (default '())))
+
+(define (home-znc-services config)
+ "Return a <shepherd-service> for znc with CONFIG."
+ (match config
+ (($ <home-znc-configuration> znc extra-options)
+ (let* ((znc (file-append znc "/bin/znc"))
+ (command `(,znc
+ "--foreground"
+ ,@extra-options))
+ (log-file (string-append %user-log-dir "/znc.log")))
+ (list (shepherd-service
+ (documentation "Run the znc IRC bouncer.")
+ (provision '(znc))
+ (start #~(make-forkexec-constructor '#$command
+ #:log-file #$log-file))
+ (stop #~(make-kill-destructor))))))))
+
+(define home-znc-service-type
+ (service-type
+ (name 'home-znc)
+ (default-value (home-znc-configuration))
+ (extensions
+ (list (service-extension home-shepherd-service-type
+ home-znc-services)))
+ (description
+ "Install and configure @command{znc}, an @acronym{IRC, Internet Relay
+Chat} bouncer, as a Shepherd service.")))