summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-08-27 16:18:31 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-27 16:20:21 +0200
commit61560d4bef05711db86320794437e1b261f4b5aa (patch)
tree36169a6d55be150e07b4ce64bbb5467653254a6a /gnu/packages/admin.scm
parent17f168fcadcae78284d2b88accb4250a2e0d43fa (diff)
gnu: inetutils: Do not refer to canonical coreutils.
Make sure not to retain a reference to the canonical coreutils package. The Guix System closure size would otherwise be increased by including references to both canonical and non-canonical version of those packages. * gnu/packages/admin.scm (inetutils)[inputs]: Add "coreutils", [arguments]: and point to it with PATHDEF_CP variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5efe67b0cb..a1b9761633 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -623,10 +623,16 @@ re-executing them as necessary.")
"--disable-uucpd"
"--disable-whois")
'()))
+ ;; Make sure that canonical "coreutils" package is not referred.
+ #:make-flags
+ (list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
+ (assoc-ref %build-inputs "coreutils*")
+ "/bin/cp\\\""))
;; On some systems, 'libls.sh' may fail with an error such as:
;; "Failed to tell switch -a apart from -A".
#:parallel-tests? #f))
- (inputs `(("ncurses" ,ncurses)
+ (inputs `(("coreutils*" ,coreutils)
+ ("ncurses" ,ncurses)
("readline" ,readline))) ;for 'ftp'
(native-inputs (if (member (%current-system)
(package-supported-systems net-tools))