summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 18:53:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 03:01:39 +0100
commita0d4d2d8605e771eefde8713756c5d6c3f98c9f7 (patch)
tree48be4f78e4081dc6635f600a6037f7b9ffca80bc /gnu/packages/algebra.scm
parent4082f8ed342b74e8ceee1bc114186a7d9ce352e7 (diff)
gnu: fftw: Update to 3.3.7.
* gnu/packages/algebra.scm (fftw): Update to 3.3.7. (fftw-3.3.7): Remove, and... (fftw-avx): ...update the only caller.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm24
1 files changed, 5 insertions, 19 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2bc8431033..f90439655f 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
@@ -516,17 +516,16 @@ a C program.")
(license license:bsd-3)))
(define-public fftw
- ;; TODO: Make this 3.3.7 (see below) on the next upgrade cycle.
(package
(name "fftw")
- (version "3.3.5")
+ (version "3.3.7")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.fftw.org/pub/fftw/fftw-"
version".tar.gz"))
(sha256
(base32
- "1kwbx92ps0r7s2mqy7lxbxanslxdzj7dp7r7gmdkzv1j8yqf3kwf"))))
+ "0wsms8narnbhfsa8chdflv2j9hzspvflblnqdn7hw8x5xdzrnq1v"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -576,25 +575,12 @@ cosine/ sine transforms or DCT/DST).")
(string-append (package-description fftw)
" With OpenMPI parallelism support."))))
-(define-public fftw-3.3.7
- ;; TODO: Make this the default 'fftw' on the next upgrade cycle.
- (package
- (inherit fftw)
- (version "3.3.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.fftw.org/pub/fftw/fftw-"
- version".tar.gz"))
- (sha256
- (base32
- "0wsms8narnbhfsa8chdflv2j9hzspvflblnqdn7hw8x5xdzrnq1v"))))))
-
(define-public fftw-avx
(package
- (inherit fftw-3.3.7)
+ (inherit fftw)
(name "fftw-avx")
(arguments
- (substitute-keyword-arguments (package-arguments fftw-3.3.7)
+ (substitute-keyword-arguments (package-arguments fftw)
((#:configure-flags flags ''())
;; Enable AVX & co. See details at:
;; <http://fftw.org/fftw3_doc/Installation-on-Unix.html>.