summaryrefslogtreecommitdiff
path: root/gnu/packages/apple.scm
diff options
context:
space:
mode:
authorB. Wilson <elaexuotee@wilsonb.com>2023-09-14 13:57:19 +0900
committerLudovic Courtès <ludo@gnu.org>2023-10-05 23:14:54 +0200
commit87b3ac13fe6d44fa323249aa86b30bce34be5d1b (patch)
treea1c03a1309e7c397a5168b891db4357332af9778 /gnu/packages/apple.scm
parent762fdbdef52b4c17df578478cadc8655d56171a4 (diff)
gnu: Add apple-bash.
* gnu/packages/apple.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODELS): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/apple.scm')
-rw-r--r--gnu/packages/apple.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/apple.scm b/gnu/packages/apple.scm
new file mode 100644
index 0000000000..b59eee1802
--- /dev/null
+++ b/gnu/packages/apple.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 B. Wilson <elaexuotee@wilsonb.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages apple)
+ #:use-module (gnu packages bison)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public apple-bash
+ (package
+ (name "apple-bash")
+ (version "125")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apple-oss-distributions/bash.git")
+ (commit (string-append "bash-" version))))
+ (sha256
+ (base32 "1d4s1z57yiyhgb6i22kb9al31j1fv9a4rp1bb747ny6grdvc4919"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs (list bison))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ ;; An XCode project wraps the actual bash source.
+ (chdir "bash-3.2")
+ ;; The xlocale.h header was removed in glibc 2.26.
+ (substitute* "lib/glob/smatch.c"
+ (("xlocale.h") "locale.h"))
+ ;; EBADEXEC is XNU-specific.
+ (substitute* "execute_cmd.c"
+ (("EBADEXEC") "ENOEXEC")))))))
+ (home-page "https://github.com/apple-oss-distributions/bash/")
+ (synopsis "Bash used on Apple macOS systems")
+ (description
+ "This is the version of Bash, forked from GNU Bash 3.2, released on Apple
+macOS systems.")
+ (license license:gpl2+)))