summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-15 09:40:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-30 10:11:18 +0100
commit35b9c201354a7d0026d23bdf612f5cfcae7894a4 (patch)
treedc03fd191edd898dd12111ce67494c12e21ef7a0 /gnu/packages/astronomy.scm
parent5a1930bf9a6e3810ad6972d4ddabdf7c14802f9e (diff)
gnu: python-fitsio: Update to 1.2.4.
* gnu/packages/astronomy.scm (python-fitsio): Update to 1.2.4. Change-Id: I82c7b8c85c3d61a8fd83e786a109914c4c91dbe2
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bddb841cbe..a51ddc5afb 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -948,21 +948,21 @@ exitinction laws found in the literature.")
(define-public python-fitsio
(package
(name "python-fitsio")
- (version "1.2.1")
+ (version "1.2.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "fitsio" version))
(sha256
- (base32 "19him5rcpjyz14ghkmifnd1xl3ivlyy84h45k6j2pyr5ixc60ky6"))
+ (base32 "0y7n7wh73ha6439djrhwmqbvgpagrdgaasbrikvw2zb5qx3y6zym"))
(modules '((guix build utils)))
(snippet
;; Remove the bundled cfitsio. When update the package check the
;; current bundled version.
#~(begin
- (delete-file-recursively "cfitsio-4.2.0")
+ (delete-file-recursively "cfitsio-4.4.1-20240617")
(substitute* "MANIFEST.in"
- (("recursive-include cfitsio-4.2.0.*$\n") ""))))))
+ (("recursive-include cfitsio-4.4.0.*$\n") ""))))))
(build-system pyproject-build-system)
(arguments
(list