summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-12-16 04:18:49 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-12 21:42:06 +0000
commit4212549eb1ed34b935c2a3b589e6f3cab6214b3b (patch)
treed63a15599f135418f234a84dc980501d3e968e09 /gnu/packages/astronomy.scm
parentb47e949fbe122836f9297f2317760af441cab8a7 (diff)
gnu: python-photutils: Update to 1.10.0.
* gnu/packages/astronomy.scm (python-photutils): Update to 1.10.0. [propagated-inputs]: Add python-bottleneck, python-gwcs, python-matplotlib, python-rasterio, python-scikit-image, python-scikit-learn, python-scipy, python-shapely, and python-tqdm. [native-inputs]: Add python-semantic-version. Change-Id: Ic2a879b653b56b84fff826b85108088db5cbf888
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2017b791c7..1b707ffc56 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2066,13 +2066,13 @@ the easy construction of interactive matplotlib widget based animations.")
(define-public python-photutils
(package
(name "python-photutils")
- (version "1.9.0")
+ (version "1.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "photutils" version))
(sha256
- (base32 "0gjvrmcb10lyqx3h9521zqskqngd5xcp3l9h2b02mk1p7q54mzdy"))))
+ (base32 "148zhdxhlcgj6dxyzaz78bzxw1q44qa9q9sfdqbfbla0s0w2jaay"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2091,11 +2091,22 @@ the easy construction of interactive matplotlib widget based animations.")
(make-file-writable "photutils/_compiler.c")
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs
- (list python-astropy python-numpy))
+ (list python-astropy
+ python-bottleneck
+ python-gwcs
+ python-matplotlib
+ python-numpy
+ python-rasterio
+ python-scikit-image
+ python-scikit-learn
+ python-scipy
+ python-shapely
+ python-tqdm))
(native-inputs
(list python-cython
python-extension-helpers
python-pytest-astropy
+ python-semantic-version
python-setuptools-scm))
(home-page "https://github.com/astropy/photutils")
(synopsis "Source detection and photometry")