summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-06-25 22:28:13 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:00 +0200
commit818405bb42d8ed157b007eb69b007183a2521dfd (patch)
treef9d34cbec0cd5600710701ca385421afe57d3e91 /gnu/packages/astronomy.scm
parenta6f9df4c411f85c3430392d939040e9c60261083 (diff)
gnu: weightwatcher: Fetch sources from Git.
They were removed from the home page. * gnu/packages/astronomy.scm (weightwatcher)[source]: Use GIT-FETCH and GIT-FILE-NAME. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b47fa8fe1e..bcc17b1056 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -706,11 +706,13 @@ header.")
(version "1.12")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/weightwatcher/"
- "weightwatcher-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/weightwatcher")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1zaqd8d9rpgcwjsp92q3lkfaa22i20gppb91dz34ym54swisjc2p"))))
+ (base32 "0701z6bdqq32jv7ga3n6jh27q684ni0hbfjm1mak7rh0qqx089gi"))))
(build-system gnu-build-system)
(arguments
(list