summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-11-12 21:21:12 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 12:35:55 +0100
commitbf9a1dfd591d5e166581919ac92e67f47219f0eb (patch)
tree798c255899e7657c1dbb068c3f2bd7162b905afe /gnu/packages/astronomy.scm
parentc663d037aa3f410706e110ce30b3e07c3edc2870 (diff)
gnu: Add imppg
* gnu/packages/astronomy.scm: (imppg): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 8b2dd57490..6ae69b8370 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -57,6 +58,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -987,6 +989,57 @@ provide you with detailed information about each pass.")
It can be used to calculate the trajectory of satellites.")
(license license:asl2.0))))
+(define-public imppg
+ (package
+ (name "imppg")
+ (version "0.6.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GreatAttractor/imppg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04synbmyz0hkipl1cdc26nr42r57v494yjw8pi4jx0jrxrawgj9h"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no test provided
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (mkdir-p "build")
+ (chdir "build")
+ (invoke
+ "cmake"
+ "-G" "Unix Makefiles"
+ "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" (assoc-ref outputs "out"))
+ ".."))))))
+ (native-inputs
+ `(("boost" ,boost)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cfitsio" ,cfitsio)
+ ("freeimage" ,freeimage)
+ ("glew" ,glew)
+ ("wxwidgets" ,wxwidgets)))
+ (home-page "https://github.com/GreatAttractor/imppg")
+ (synopsis "Astronomical Image Post-Proccessor (ImPPG)")
+ (description
+ "ImPPG performs Lucy-Richardson deconvolution, unsharp masking,
+brightness normalization and tone curve adjustment. It can also apply
+previously specified processing settings to multiple images. All operations
+are performed using 32-bit floating-point arithmetic.
+
+Supported input formats: FITS, BMP, JPEG, PNG, TIFF (most of bit depths and
+compression methods), TGA and more. Images are processed in grayscale and can
+be saved as: BMP 8-bit; PNG 8-bit; TIFF 8-bit, 16-bit, 32-bit
+floating-point (no compression, LZW- or ZIP-compressed), FITS 8-bit, 16-bit,
+32-bit floating-point.")
+ (license license:gpl3+)))
+
(define-public indi
(package
(name "indi")