summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-08 02:30:08 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-20 14:10:43 +0100
commitc08fda0716aefe1b9bd45df024523fcdf7f7e941 (patch)
treeb11b41e17e289d233be033a26ac35e69915c95b1 /gnu/packages/astronomy.scm
parentc599d309c43fc71160af99ceade5fad16c913a11 (diff)
gnu: stellarium: Update to 1.2.
* gnu/packages/astronomy.scm (stellarium): Update to 1.2. [arguments]{tests}: Disable tests, with further review of INDI package. [arguments]{configure-flags}: Explicitly disable Qt6 (prevent failing build) and ShowMySky (not packed yet). [phases]{set-offscreen-display}: Remove trail #T in lambda. [inputs]: Remove labels and add GPSD, INDI, LIBNOVA, OPENSSL, QTCHARTS, QTPOSITIONING, QTTRANSLATIONS, QTWEBENGINE-5, QXLSX. [native-inputs]: Remove labels and add DOXYGEN, GRAPHVIZ, MESA, PYTHON-WRAPPER. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm77
1 files changed, 51 insertions, 26 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2f08b656c0..5cee981671 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
@@ -44,6 +45,8 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gps)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
@@ -70,6 +73,7 @@
#:use-module (gnu packages sphinx)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages wxwidgets)
@@ -835,45 +839,66 @@ deconvolution). Such post-processing is not performed by Stackistry.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.21.1")
+ (version "1.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Stellarium/stellarium"
- "/releases/download/v" version
- "/stellarium-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Stellarium/stellarium")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "049jlc8vx06pad5h2syrmf7f1l346yr5iraai0wkn8s8pk30j8q7"))))
+ (base32 "1655lz848k7m4vqs7n3vxjwn5n4pkykwl6x7nbanqcqzlixm5xnk"))))
(build-system cmake-build-system)
+ ;; TODO: Complete documentation build and split into dedicated outputs.
+ (arguments
+ (list
+ ;; FIXME: Tests keep failing on 100% when preparing test-suit for INDI.
+ #:tests? #f
+ #:test-target "test"
+ #:configure-flags
+ #~(list "-DENABLE_GPS=1"
+ ;; TODO: Enable when all of the dependencies are availalbe for Qt6.
+ "-DENABLE_QT6=0"
+ ;; TODO: Pack missing in Guix https://10110111.github.io/CalcMySky/
+ "-DENABLE_SHOWMYSKY=0"
+ "-DENABLE_TESTING=0"
+ (string-append "-DCMAKE_CXX_FLAGS=-isystem "
+ #$(this-package-input "qtserialport") "/include/qt5"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp"))))))
(inputs
- (list qtbase-5
+ (list gpsd
+ indi
+ libnova
+ openssl
+ qtbase-5
+ qtcharts
qtlocation
qtmultimedia-5
+ qtpositioning
qtscript
qtserialport
+ qttranslations
+ qtwebengine-5
+ qxlsx
zlib))
(native-inputs
- `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
- ("perl" ,perl) ; for pod2man
- ("qtbase" ,qtbase-5) ; Qt MOC is needed at compile time
- ("qttools-5" ,qttools-5)))
- (arguments
- `(#:test-target "test"
- #:configure-flags (list "-DENABLE_TESTING=1"
- (string-append
- "-DCMAKE_CXX_FLAGS=-isystem "
- (assoc-ref %build-inputs "qtserialport")
- "/include/qt5"))
- #:phases (modify-phases %standard-phases
- (add-before 'check 'set-offscreen-display
- (lambda _
- ;; Make Qt render "offscreen", required for tests.
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
+ (list doxygen
+ gettext-minimal
+ graphviz
+ mesa
+ perl
+ python-wrapper
+ qttools-5))
(home-page "https://stellarium.org/")
(synopsis "3D sky viewer")
- (description "Stellarium is a planetarium. It shows a realistic sky in
+ (description
+ "Stellarium is a planetarium. It shows a realistic sky in
3D, just like what you see with the naked eye, binoculars, or a telescope. It
can be used to control telescopes over a serial port for tracking celestial
objects.")