summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-21 08:03:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-30 10:11:19 +0100
commiteb58258b43eef9bb459555baf0fad62ba35bb044 (patch)
tree8da7c82cf8473e23deeee65a52f321221a583c5b /gnu/packages/astronomy.scm
parent865f53b8c7cd11e478ae8ad9a39cf19c158d1eb6 (diff)
gnu: python-stsci-stimage: Update to 0.2.9.
* gnu/packages/astronomy.scm (python-stsci-stimage): Update to 0.2.9. [native-inputs]: Add python-wheel. Change-Id: I87595ff5b40506451e69057cde249af0ac6462ea
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1ea0c8ce7c..bed1d93b83 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3288,16 +3288,17 @@ task}.")
(name "python-stsci-stimage")
;; PyPI version was 0.2.8 but the latest version tag on GiHub was 0.2.7,
;; see <https://github.com/spacetelescope/stsci.stimage/issues/38>
- (version "0.2.8")
+ (version "0.2.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "stsci_stimage" version))
(sha256
(base32
- "0p188my6djy65a8j6qsc3v0dpr2svqqv90n0pxxzy52vdjiz3w0w"))))
+ "18sqmjiyn76hzkmv3g8549vfygi136gnar6pb0s7wb44j7cvc0in"))))
(build-system pyproject-build-system)
(arguments
(list
+ #:build-backend "setuptools.build_meta"
#:test-flags #~(list "test_c")
#:phases
#~(modify-phases %standard-phases
@@ -3312,7 +3313,10 @@ task}.")
(propagated-inputs
(list python-numpy))
(native-inputs
- (list python-pytest python-setuptools-scm python-waf))
+ (list python-pytest
+ python-wheel
+ python-setuptools-scm
+ python-waf))
(home-page "https://stscistimage.readthedocs.io/en/latest/")
(synopsis "STScI image processing")
(description