summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-09 00:40:16 +0100
committerChristopher Baines <mail@cbaines.net>2023-10-11 12:11:42 +0100
commiteef6d037fae0bddcc19a82f7605d7870340d8491 (patch)
tree59ab5e3378af2b974ac5226b4d1c999de72c23c8 /gnu/packages/astronomy.scm
parentbf6bab4e95ca34dce9e2816284a4fc0f0a3fe5e8 (diff)
gnu: python-stcal: Update package style.
* gnu/packages/astronomy.scm (python-stcal): Update indentation to improve readability of the package. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm53
1 files changed, 29 insertions, 24 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index af19585b6f..036762ab8c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2578,32 +2578,37 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(package
(name "python-stcal")
(version "1.4.4")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "stcal" version))
- (sha256
- (base32
- "031ldihdmsdrwz4wl49bfk2bxmzbp1i3kidrw46xz936765zmnc0"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stcal" version))
+ (sha256
+ (base32 "031ldihdmsdrwz4wl49bfk2bxmzbp1i3kidrw46xz936765zmnc0"))))
(build-system pyproject-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- ;; XXX: Can't detect opencv-python version. The input
- ;; opencv might not set the version correctly.
- (delete 'sanity-check)
- (add-before 'check 'build-extensions
- (lambda _
- ;; Cython extensions have to be built before
- ;; running the tests.
- (invoke "python" "setup.py" "build_ext" "--inplace"))))))
- (propagated-inputs (list opencv ;Provides OpenCV-Python
- python-astropy python-numpy python-scipy))
- (native-inputs (list python-cython
- python-psutil
- python-pytest
- python-pytest-cov
- python-pytest-doctestplus
- python-pytest-openfiles
- python-setuptools-scm))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Can't detect opencv-python version. The input opencv might
+ ;; not set the version correctly.
+ (delete 'sanity-check)
+ (add-before 'check 'build-extensions
+ (lambda _
+ ;; Cython extensions have to be built before running the tests.
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (propagated-inputs
+ (list opencv ;Provides OpenCV-Python
+ python-astropy
+ python-numpy
+ python-scipy))
+ (native-inputs
+ (list python-cython
+ python-psutil
+ python-pytest
+ python-pytest-cov
+ python-pytest-doctestplus
+ python-pytest-openfiles
+ python-setuptools-scm))
(home-page "https://github.com/spacetelescope/stcal")
(synopsis "STScI tools and algorithms used in calibration pipelines")
(description "STScI tools and algorithms used in calibration pipelines.")