summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-07 23:06:49 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-21 14:25:12 +0000
commitf99a1e257d7ba5995afcf05f429d79d6f097a517 (patch)
treee88e0b316ad1f466174baf63262e93157c2f6d9f /gnu/packages/astronomy.scm
parent1b03c64a05a319631a82cd15b9dda914e94c5142 (diff)
gnu: Add asdf-unit-schemas.
* gnu/packages/astronomy.scm (python-asdf-unit-schemas): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2eac10457d..2b3f0f61e2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2094,6 +2094,28 @@ coordinates tags. Users should not need to install this directly; instead,
install an implementation package such as asdf-astropy.")
(license license:bsd-3)))
+(define python-asdf-unit-schemas
+ (package
+ (name "python-asdf-unit-schemas")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf_unit_schemas" version))
+ (sha256
+ (base32
+ "16grpx3a9h0v1wirp0zqrfsxm867v5c0xyr98pylzziy45kqvds2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Dependency cycle with python-asdf
+ (list #:tests? #f))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-asdf-standard python-importlib-resources))
+ (home-page "https://asdf-unit-schemas.readthedocs.io/")
+ (synopsis "ASDF serialization schemas for the units defined by @code{astropy.units}")
+ (description "This package provides ASDF schemas for validating unit tags.")
+ (license license:bsd-3)))
+
(define-public python-asdf-astropy
(package
(name "python-asdf-astropy")