summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-11-22 11:23:55 -0500
committerKei Kebreau <kei@openmailbox.org>2016-11-22 11:24:41 -0500
commitc3cc7d412a04d76b555853f6105842acadba4595 (patch)
tree39cb6753801470a76173ce08ed9a973375711c35 /gnu/packages/audio.scm
parent52db41aff8771518f99eb1f9b63b814b568f7a4a (diff)
gnu: Add espeak.
* gnu/packages/audio.scm (espeak): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 77d3b538c8..492f716ca9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -343,6 +343,57 @@ tools (analyzer, mono/stereo tools, crossovers).")
;; The plugins are released under LGPLv2.1+
(license (list license:lgpl2.1+ license:gpl2+))))
+(define-public espeak
+ (package
+ (name "espeak")
+ (version "1.48.04")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/espeak/espeak/"
+ "espeak-" (version-major+minor version)
+ "/espeak-" version "-source.zip"))
+ (sha256
+ (base32
+ "0n86gwh9pw0jqqpdz7mxggllfr8k0r7pc67ayy7w5z6z79kig6mz"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; remove prebuilt binaries
+ '(delete-file-recursively "linux_32bit"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "DATADIR="
+ (assoc-ref %outputs "out")
+ "/share/espeak-data")
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib")
+ "AUDIO=pulseaudio")
+ #:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (chdir "src")
+ ;; We use version 19 of the PortAudio library, so we must copy the
+ ;; corresponding file to be sure that espeak compiles correctly.
+ (copy-file "portaudio19.h" "portaudio.h")
+ (substitute* "Makefile"
+ (("/bin/ln") "ln"))
+ #t)))))
+ (inputs
+ `(("portaudio" ,portaudio)
+ ("pulseaudio" ,pulseaudio)))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://espeak.sourceforge.net/")
+ (synopsis "Software speech synthesizer")
+ (description "eSpeak is a software speech synthesizer for English and
+other languages. eSpeak uses a \"formant synthesis\" method. This allows many
+languages to be provided in a small size. The speech is clear, and can be used
+at high speeds, but is not as natural or smooth as larger synthesizers which are
+based on human speech recordings.")
+ (license license:gpl3+)))
+
(define-public infamous-plugins
(package
(name "infamous-plugins")